Для того, чтобы описать условие в функции ЕСЛИ, Excel позволяет использовать более сложные конструкции. В том числе можно использовать и несколько условий. Воспользуемся тем, что функции в Excel можно вкладывать внутрь друг друга.

Для объединения нескольких условий в одно используем логические функции ИЛИ и И. Рассмотрим простые примеры.

Пример 1

функция ЕСЛИ с несколькими условиями

Функция ИЛИ возвращает ИСТИНА, если хотя бы одно из перечисленных в ней нескольких условий выполняется.

=ЕСЛИ(ИЛИ(C2="Восток",C2="Юг"),"Экспорт","Местные")

Вставляем функцию ИЛИ как условие в функцию ЕСЛИ. В нашем случае, если регион покупателя - Восток или Юг, то отгрузка считается экспортом.

Пример 2.

Используем несколько более сложных условий внутри функции ЕСЛИ.

Если регион продажи - Запад или Юг, и количество при этом больше 100, то предоставляется скидка 10%.

=ЕСЛИ(И(ИЛИ(C2="Запад",C2="Юг"),E2>100),F2*0.1,0)

Функция И возвращает ИСТИНА, если выполняются все перечисленные в ней условия. Внутрь функции И мы помещаем два условия:

  1. Регион - или Запад или Юг
  2. Количество больше 100.

Первое из них реализуем так же, как это было сделано в первом примере: ИЛИ(C2="Запад",C2="Юг")

Второе - здесь всё очень просто: E2>100

В строке 2, 3 и 5 выполнены оба условия. Эти покупатели получат скидку.

В строке 4 не выполнено ни одного. А в строке 6,7,8 выполнено только первое, а вот количество слишком мало. Поэтому скидка будет равна нулю.

Пример 3.

Конечно, эти несколько условий могут быть и более сложными. Ведь логические функции можно "вкладывать" друг в друга.

Например, в дополнение к предыдущему условию, скидка предоставляется только на черный шоколад.

Все наше записанное ранее условие становится в свою очередь первым аргументом в новой функции И:

  1. Регион - Запад или Юг и количество больше 100 (рассмотрено в примере 2)
  2. В названии шоколада встречается слово "черный".

В итоге получаем формулу ЕСЛИ с несколькими условиями:

=ЕСЛИ(И(ЕЧИСЛО(НАЙТИ("Черный",D2)),
И(ИЛИ(C2="Запад",C2="Юг")),E2>100),F2*0.1,0)

Функция НАЙТИ ищет точное совпадение. Если же регистр символов в тексте для нас не важен, то вместо НАЙТИ можно использовать аналогичную функцию СОВПАД.

=ЕСЛИ(И(ЕЧИСЛО(СОВПАД("черный",D2)),
И(ИЛИ(C2="Запад",C2="Юг")),E2>100),F2*0.1,0)

В итоге, количество вложенных друг в друга условий в Excel может быть очень большим. Важно только точно соблюдать логическую последовательность их выполнения.

Еще примеры использования функции ЕСЛИ:

вычисления при условии непустых ячеек Excel Функция ЕСЛИ: производим действия в зависимости от условия - Чтобы выполнить действие только тогда, когда ячейка не пуста (содержит какие-то значения), вы можете использовать формулу, основанную на функции ЕСЛИ. В примере ниже столбец F содержит даты завершения закупок шоколада.…
проверка правильности ввода Excel при помощи функции ЕСЛИ Как проверить правильность ввода данных в Excel? - Подтверждаем правильность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить…
ЕСЛИ + СОВПАД текст Функция ЕСЛИ: проверяем условия с текстом - Рассмотрим использование функции ЕСЛИ в Excel в том случае, если в ячейке находится текст. СодержаниеПроверяем условие для полного совпадения текста.ЕСЛИ + СОВПАДИспользование функции ЕСЛИ с частичным совпадением текста.ЕСЛИ + ПОИСКЕСЛИ…
функция если Визуализация данных при помощи функции ЕСЛИ - Функцию ЕСЛИ можно использовать для вставки в таблицу символов, которые наглядно показывают происходящие с данными изменения. К примеру, мы хотим показать в отдельной колонке таблицы, происходит рост или снижение продаж.…
ЕСЛИ с датами 3 примера, как функция ЕСЛИ работает с датами. - На первый взгляд может показаться, что функцию ЕСЛИ для работы с датами можно использовать так же, как для числовых и текстовых значений, которые мы только что обсудили. К сожалению, это…
Функция ЕСЛИ в Excel – примеры использования - на примерах рассмотрим, как можно использовать функцию ЕСЛИ в Excel, а также какие задачи мы можем решить с ее помощью