Функция ЕСЛИ в Google таблицах – это одна из самых простых функций, но при этом она очень полезна. Она относится к десятку функций, которые нужно обязательно знать и уметь применять.

Сейчас мы подробно рассмотрим, как применяется функция ЕСЛИ в таблицах Google, а также какую пользу мы можем получить от ее использования.

Что такое функция ЕСЛИ в Google таблицах?

Она позволяет создать дерево решений, в котором при выполнении условия происходит одно действие, а если условие не выполняется – происходит другое действие. При этом условие в функции ЕСЛИ должно быть вопросом, на который есть 2 варианта ответа: «да» и «нет». Вот как может выглядеть это дерево решений.

выбор альтернатив

Итак, функция ЕСЛИ позволяет задать вопрос и указать 2 варианта действий в зависимости от полученного ответа. Этот вопрос и варианты действий являются тремя аргументами функции.

Синтаксис функции ЕСЛИ в Google таблицах.

[box] =ЕСЛИ(источникзначение при соблюдении условиязначение при несоблюдении условия[/box]
  • источник - логическое значение или адрес ячейки, содержащей такое значение (например, Истина или Ложь).
  • значение при соблюдении условия - функция будет возвращать это значение, если источник соответствует логическому значению Истина.
  • значение при несоблюдении условия - функция будет возвращать это значение, если источник соответствует логическому значению Ложь.

Давайте вместе подробнее рассмотрим аргументы функции ЕСЛИ.

Первый аргумент – это логический вопрос. Google таблица дает ответ на этот вопрос, и ответ этот может быть только «да» или «нет», «истина» или «ложь».

Как правильно задать такой вопрос? Для этого можно записать логическое выражение, используя знаки “=”, “>”, “<”, “>=”, “<=”, “<>”. Давайте попробуем задать такой вопрос вместе.

Пример использования функции IF.

Предположим, вы работаете в компании, которая занимается продажей шоколада в нескольких регионах и работает с множеством покупателей. Вот как выглядят данные о ваших продажах, хранящиеся в Google таблице.

данные о продажах

Нам необходимо отделить продажи, которые произошли в нашем регионе, от тех, которые были сделаны за рубежом. Для этого нужно добавить в таблицу ещё один признак для каждой продажи – страну, в которой она произошла. Поскольку данных очень много, мы хотим, чтобы этот признак создавался автоматически для каждой записи.

В этом нам поможет функция ЕСЛИ. Добавим в таблицу данных столбец “Страна”. Регион “Восток”  – это местные продажи (назовём их  "Внутри страны"), а остальные регионы – это продажи за рубеж ("Экспорт").

Как правильно записать функцию ЕСЛИ.

Устанавливаем курсор в ячейку Н2 и вводим знак “=”. Для Google таблиц это означает, что сейчас будет введена формула. Поэтому как только далее будет  введена буква “Е”, он выведет нам список - предложение выбрать функцию, начинающуюся с буквы “Е”. Выбираем “Если”.

вводим функцию ЕСЛИ

Далее все наши действия также будут сопровождаться подсказками.

В качестве первого аргумента функции ЕСЛИ вводим: D2=”Восток”. Как и в других функциях Google таблиц, адрес ячейки можно не вводить вручную, а просто кликнуть на ней мышкой. Затем вводим “,” и указываем второй аргумент.

Второй аргумент – это значение, которое примет ячейка Н2, если условие первого аргумента будет выполнено. Это будет текст “Внутри страны”.

После этого снова через запятую указываем значение третьего аргумента. Это значение примет ячейка Н2, если условие не будет выполнено: “Экспорт”. Не забываем закончить ввод формулы, нажав “)” и затем “Enter”.

функция ЕСЛИ

Наша функция выглядит следующим образом:

=ЕСЛИ(D2="Восток";"Внутри страны";"Экспорт")

Наша ячейка Н2 приняла значение “Экспорт”.

Теперь нашу функцию можно скопировать во все остальные ячейки столбца I.

Рассмотрим подробнее, как ещё можно использовать функцию IF.

Использование функции ЕСЛИ для текстовых значений.

Выше мы как раз уже рассмотрели, как использовать функцию ЕСЛИ с текстовыми данными.

Обратите внимание, что если в качестве аргумента функции мы используем текст, то он обязательно должен быть заключён в кавычки.

Использование функции IF с числовыми значениями.

Точно так же, как мы это делали с текстом, в аргументах функции можно использовать и числа.

Однако для нас важно то, что функция ЕСЛИ позволяет не только заполнять ячейки определёнными числовыми значениями в зависимости от выполнения какого-то условия, но также и производить вычисления.

К примеру, мы предоставляем нашему покупателю скидку в зависимости от суммы покупки. Если сумма больше 10000, то он получает бонус 10% от совершенных покупок.

функция ЕСЛИ с числами

Назовём столбец I “Бонус” и в ячейку I2 введём функцию ЕСЛИ, вторым аргументом которой будет формула расчёта бонуса. Это будет выглядеть так:

=ЕСЛИ(G2>10000;G2*0.1)

Примеры использования функции ЕСЛИ вместе с другими функциями.

В качестве аргумента функции ЕСЛИ можно использовать не только текст, числа или формулы, но также и другие функции. Поясним на примере.

Вспомним, как мы определяли страну, в которой произошли продажи. Предположим, что местные продажи - это не только регион Восток, но ещё и Юг.

В качестве первого аргумента в этом случае мы можем использовать функцию ИЛИ, которая возвращает «Да», если хотя бы одно из перечисленных в ней условий выполняется. Изменим нашу функцию ЕСЛИ в ячейке Н2. В первом аргументе мы перечислим все регионы, относящиеся к местным, а остальные продажи будут автоматически отнесены к иностранным.

совместное использование функций ЕСЛИ и ИЛИ

Формула выглядит следующим образом:

=ЕСЛИ(ИЛИ(D2="Восток";D2="Юг");"Внутри страны";"Экспорт")

А сейчас мы попробуем использовать функцию ЕСЛИ как аргумент другой функции ЕСЛИ.

Предположим, мы усложним условия получения дисконта для покупателя. Если сумма покупки больше 10000, то он получает  10%, если от 5000 до 9999 – то 5%.

вложенная функция ЕСЛИ

Посмотрите, как будет теперь выглядеть наша вложенная функция ЕСЛИ в ячейке I2.

=ЕСЛИ(G2>=10000;G2*0.1;ЕСЛИ(G2>5000;G2*0.05;G2))

Для этого мы использовали в качестве второго аргумента функции ЕСЛИ такую же функцию. Дерево решений при этом выглядит так:

дерево решений вложенной функции ЕСЛИ

Итак, мы с вами убедились, что простая на первый взгляд функция ЕСЛИ дает нам на самом деле много возможностей для операций с данными.