Подтверждаем правильность ввода галочкой.

Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить галочку, в случае ошибки - там же должен появиться крестик. Это позволит сразу же обнаружить ошибку ввода и своевременно ее исправить. Ведь ошибки при вводе не позволят нам правильно группировать данные, производить их поиск, производить какие-то вычисления в зависимости от выполнения определенного условия и т.д.

Общая формула, которая поможет нам проверить и отметить правильность ввода данных в ячейку Excel, выглядит следующим образом:

=ЕСЛИ(логическое условие, галочка, знак_ошибки)

Все наши допустимые значения, которые могут быть записаны в ячейку при вводе, мы расположим в отдельном диапазоне данных. В нашем случае - в ячейках Е2:Е5. Чтобы было проще работать с этими условиями, давайте обозначим эти ячейки как именованный диапазон. Назовем его "значения". Теперь вместо координат ячеек достаточно будет ввести имя диапазона - "значения". Этот набор можно при необходимости расширить.

Формула в ячейке В2 выглядит следующим образом:

=ЕСЛИ(СЧЁТЕСЛИ(значения,A2),СИМВОЛ(252),СИМВОЛ(251))

Как работает эта формула в Excel?

Чтобы отобразить галочку, если введенное значение верное, вы можете использовать формулу на основе функции ЕСЛИ вместе с шрифтом символов, таким как Wingdings.

проверка правильности ввода Excel при помощи функции ЕСЛИ

Для проверки условия мы используем функцию СЧЕТЕСЛИ.

=СЧЁТЕСЛИ(значения,A2)

Здесь мы считаем, сколько раз значение из ячейки А2 встречается в диапазоне "значения". Если его там нет, то функция СЧЕТЕСЛИ возвратит 0. И этот ноль будет воспринят функцией ЕСЛИ как отрицательный ответ на поставленное условие. Если все введено верно и введенный текст был найден в контрольном списке, то будет возвращена 1, которая будет воспринята как "Да". Это прекрасно работает как логическое условие для функции ЕСЛИ.

Обратите внимание, что здесь используется одна важная особенность Excel: если в качестве аргумента функции ЕСЛИ используется какая-то функция, результатом вычисления которой будет число, то функция ЕСЛИ любое число, отличное от нуля, преобразует в "ИСТИНА", а ноль - в "ЛОЖЬ".

Кстати, и в обратном направлении тоже работает: если в математической формуле в качестве одного из аргументов использовать любую логическую функцию (в том числе и ЕСЛИ) и попытаться проделать с ним математические вычисления, то результат выполнения логической функции будет представлен в виде числа - 0 либо 1.

Чтобы вывести галочку в случае верного ввода, используем функцию СИМВОЛ, которая преобразует код в символ.

коды символов Excel

Не забудьте в ячейках, показывающих результат проверки ввода данных в Excel, использовать шрифт Wingdings.

Но вообще-то в случае, если приходится часто вводить повторяющиеся данные, и чтобы избежать ошибок при вводе, рекомендуется использовать выпадающий список. Предоставляем вам возможность самим сравнить и выбрать лучший для себя вариант.

Как создать выпадающий список в Excel - подробные инструкции для "чайников" и не только ....

Выпадающий список - лучшая гарантия правильности ввода данных.

Ещё примеры использования функции ЕСЛИ и СЧЕТЕСЛИ:

Функция СЧЁТЕСЛИМН в Excel с несколькими условиями — объясняем на примерах. - В этом руководстве объясняется, как использовать функцию СЧЕТЕСЛИМН с несколькими критериями в Excel на основе логики И и ИЛИ. Вы найдете примеры для разных типов данных - числа, даты, текст,…
СЧЕТЕСЛИ в Excel - примеры функции с одним и несколькими условиями - В этой статье мы сосредоточимся на функции Excel СЧЕТЕСЛИ (COUNTIF в английском варианте), которая предназначена для подсчета ячеек с определённым условием. Сначала мы кратко рассмотрим синтаксис и общее использование, а затем я…
несколько вложенных условий в функции ЕСЛИ Функция ЕСЛИ: примеры с несколькими условиями - Для того, чтобы описать условие в функции ЕСЛИ, Excel позволяет использовать более сложные конструкции. В том числе можно использовать и несколько условий. Воспользуемся тем, что функции в Excel можно вкладывать…
вычисления при условии непустых ячеек Excel Функция ЕСЛИ: производим действия в зависимости от условия - Чтобы выполнить действие только тогда, когда ячейка не пуста (содержит какие-то значения), вы можете использовать формулу, основанную на функции ЕСЛИ. В примере ниже столбец F содержит даты завершения закупок шоколада.…
ЕСЛИ + СОВПАД текст Функция ЕСЛИ: проверяем условия с текстом - Рассмотрим использование функции ЕСЛИ в Excel в том случае, если в ячейке находится текст. СодержаниеПроверяем условие для полного совпадения текста.ЕСЛИ + СОВПАДИспользование функции ЕСЛИ с частичным совпадением текста.ЕСЛИ + ПОИСКЕСЛИ…
функция если Визуализация данных при помощи функции ЕСЛИ - Функцию ЕСЛИ можно использовать для вставки в таблицу символов, которые наглядно показывают происходящие с данными изменения. К примеру, мы хотим показать в отдельной колонке таблицы, происходит рост или снижение продаж.…
ЕСЛИ с датами 3 примера, как функция ЕСЛИ работает с датами. - На первый взгляд может показаться, что функцию ЕСЛИ для работы с датами можно использовать так же, как для числовых и текстовых значений, которые мы только что обсудили. К сожалению, это…
Функция ЕСЛИ в Excel – примеры использования - на примерах рассмотрим, как можно использовать функцию ЕСЛИ в Excel, а также какие задачи мы можем решить с ее помощью