В этом руководстве вы узнаете, как отображать дубликаты в Excel. Мы рассмотрим различные методы затенения дублирующих ячеек, целых строк или последовательных повторений с использованием условного форматирования. 

Ранее мы исследовали различные способы как найти дубликаты в Excel. Несомненно, эти формулы очень полезны, но выделение повторяющихся записей определенным цветом может сделать анализ данных еще проще.

Самый быстрый способ найти и подсветить повторы в Excel - это использовать условное форматирование. Самое большое преимущество этого метода в том, что он не только показывает существующие совпадения, но и обнаруживает и сразу же окрашивает новые повторы при вводе, редактировании или перезаписи ваших данных.

Далее в этом руководстве вы найдете несколько способов выделения дубликатов записей в зависимости от конкретной задачи. Эти методы работают во всех версиях Excel 2016, Excel 2013, Excel 2010 и ниже.

Как подсветить дубликаты, используя встроенный инструмент (с 1-м появлением)

Для начала, во всех версиях Excel есть заготовка для выделения дублирующих ячеек. Чтобы использовать это её в своих таблицах, выполните следующие действия:

  1. Выберите данные, которые вы хотите проверить. Это может быть колонка, строка или диапазон ячеек.
  2. На вкладке « Главная » выберите « Условное форматирование» > «Правила выделения ячеек» > «Повторяющиеся значения».

Откроется диалоговое окно с форматом «Светло-красная заливка» и «Темно-красный текст», выбранными по умолчанию. Чтобы применить формат по умолчанию, просто нажмите ОК.

Помимо красной заливки и форматирования текста, в выпадающем списке доступно несколько других предопределенных форматов. Чтобы покрасить повторяющиеся ячейки другим цветом, нажмите «Пользовательский формат» (последний элемент в раскрывающемся списке) и выберите цвет заливки и/или шрифта по своему вкусу.
Подсказка. Чтобы указать цветом на уникальные значения, выберите «Уникальные» в левом поле.

И вот что мы получили в итоге:

Как видим, повторов оказалось очень много. Применяя встроенное правило дублирования к двум или более столбцам, Excel не сравнивает значения в них, а просто выделяет все дублирующиеся экземпляры. Для работы со всей таблицей или для сравнения столбцов вряд ли этот метод вам подойдет. А вот для поиска в одной колонке или строке – вполне хорош.

При использовании этого инструмента имейте в виду следующие две вещи:

  • Работает только для отдельных клеток. Чтобы отметить дублирующиеся строки, вам необходимо создать свои собственные правила.
  • Он закрашивает дубликаты ячеек, включая их первые появления. Чтобы отметить все из них, кроме первых экземпляров , создайте правило условного форматирования на основе формулы из этого руководства по нахождению дубликатов.

Как выделить повторы без 1-го вхождения

Чтобы отметить второе и все последующие повторяющиеся вхождения, выберите ячейки, которые вы хотите закрасить, и действуйте следующим образом:

  1. Выберите «Условное форматирование» > « Новое правило»> «Использовать формулу», чтобы определить ячейки для форматирования .
  2. В поле « Форматировать значения», где эта формула возвращает ИСТИНА , введите:

=СЧЕТЕСЛИ($B$2:$B2;$B2)>1

Где B2 - самая верхняя ячейка выбранного диапазона.

  1. Нажмите кнопку «Формат» выберите нужный цвет заливки и/или шрифта.
  2. Наконец, нажмите кнопку ОК, чтобы сохранить и применить созданное.

Если у вас нет большого опыта работы с условным форматированием Excel, вы найдете подробные инструкции по созданию правила на основе формул в следующем руководстве:  Как изменить цвет ячейки в зависимости от значения? 

В результате дубликаты ячеек, исключая первые экземпляры, будут выделены цветом по вашему выбору.

Как показать третий, четвертый и все последующие дубликаты?

Чтобы просмотреть повторяющиеся значения, начинающиеся с N-го вхождения, действуйте как в предыдущем примере. С той лишь разницей, что вы заменяете > 1 в конце формулы на требуемое число. Например:

Чтобы раскрасить третий и все последующие повторы, примените это:

=СЧЕТЕСЛИ($B$2:$B2;$B2)>=3

Чтобы указать на 4-е и все последующие повторяющиеся записи, используйте выражение:

=СЧЕТЕСЛИ($B$2:$B2;$B2)>=4

Чтобы выделить только определенные вхождения, используйте оператор равенства (=). 

Например, чтобы изменить фон только 2-х экземпляров, вы должны использовать следующую формулу:

=СЧЕТЕСЛИ($B$2:$B2;$B2)=2

Как выделить дубликаты в диапазоне

Если вы хотите проверить наличие повторяющихся данных в какой-то области данных, обнаружив все экземпляры одного и того же элемента, используйте одно из следующих решений.

Выделите дубликаты в таблице, включая 1-е  вхождение.

Если первый экземпляр элемента, который появляется в наборе данных более одного раза, считается дубликатом, проще всего воспользоваться встроенным правилом Excel для дубликатов, о котором мы говорили выше.

Или создайте своё условное форматирование:

=СЧЕТЕСЛИ(диапазонпервая_ячейка)> 1

Например, чтобы отметить цветом совпадения в диапазоне A2: C8, сделайте это следующим образом:

=СЧЕТЕСЛИ($A$2:$C$8, A2)>1

Обратите внимание на использование абсолютных ссылок на ячейки для диапазона ($A$2:$C$8) и относительных ссылок для верхней ячейки (A2).

Выделите повторы в таблице без 1-го вхождения.

Решение для этого сценария намного сложнее. Не удивительно, что в Excel нет для него готового решения :)

Чтобы выделить повторяющиеся значения в нескольких колонках, игнорируя первое появление, вам нужно будет создать 2 правила со следующими формулами:

Правило 1. Относится к первому столбцу.

Здесь вы используете точно такую ​​же формулу, как мы использовали для выделения дубликатов без 1- го вхождения в одном столбце (подробные шаги можно найти здесь ).

В этом примере мы применяем для A2: A11 условие:

=СЧЁТЕСЛИ($A$2:$A2;A2)>1

В результате дублирующие элементы без 1- го вхождения выделяются в крайнем левом столбике диапазона (в нашем случае есть только два таких элемента):

Правило 2. Относится ко всем последующим колонкам

Чтобы выделить дубликаты в оставшихся данных (B2: C11), используйте следующую формулу:

=СЧЁТЕСЛИ(A$2:$A$11;B2)+СЧЁТЕСЛИ(B$2:B2;B2)>1

В приведенной выше формуле первая функция СЧЕТЕСЛИ подсчитывает вхождения данного элемента в первом столбце, а второй СЧЕТЕСЛИ делает то же самое для всех последующих. Затем вы складываете эти числа и проверяете, больше ли сумма, чем 1.

В результате все дублированные элементы, за исключением их 1- го вхождения, будут найдены и выделены:

Выделение целых строк на основе повторяющихся значений в одной колонке.

Если ваша таблица содержит несколько колонок, вы можете выделить целые строки на основе повторяющихся записей в одной из них.

Как вы уже знаете, встроенное правило Excel для дубликатов работает только на уровне ячеек. Но при использовании собственных формул нет проблем с закраской строк целиком. Ключевым моментом является выделение целых строк, а затем создание правила с одной из следующих формул:

  • Чтобы выделить дублирующиеся строки, исключая первые вхождения:

=СЧЁТЕСЛИ($B$2:$B2;$B2)>1

Выделяем строки с одинаковыми наименованиями товаров (столбец B)

  • Чтобы выделить повторяющиеся строки, включая все вхождения:

= СЧЁТЕСЛИ ($B$2:$B$17;$B2)>1

Здесь B2 - первая ячейка, а B17 - последняя, которую вы хотите проверить на наличие дублей. 

Как видите, разумное использование абсолютных и относительных ссылок имеет значение.

Как выделить дублирующиеся строки в Excel

В предыдущем примере демонстрировалось, как окрашивать целые строки при появлении повторяющихся значений в определенной колонке. Но что, если вы хотите просмотреть строки с одинаковыми значениями в нескольких колонках? Или как выделить из них абсолютно одинаковые, которые имеют совершенно одинаковые значения?

Для этого используйте функцию СЧЁТЕСЛИМН, которая позволяет сравнивать по нескольким критериям. Например, чтобы выделить строки с одинаковыми значениями в B и C, то есть найти заказы одного и того же товара одним заказчиком, используйте одну из следующих формул:

  • Чтобы выделить совпадающие, кроме 1-го вхождения :

=COUNTIFS($A$2:$A2, $A2, $B$2:$B2, $B2)>1

Обратите внимание, что форматирование мы применяем ко всей таблице.

  • Чтобы выделить все неуникальные:

=СЧЁТЕСЛИМН($B$2:$B$17; $B2; $C$2:$C$17; $C2)>1

Как вы понимаете, приведенный выше пример только для демонстрационных целей. При выделении дублирующихся строк в ваших реальных таблицах вы, естественно, не ограничены сравнением значений только в 2 столбцах. Функция СЧЁТЕСЛИМН может обрабатывать до 127 пар диапазон / критерий.

Подсветка последовательных дубликатов ячеек в Excel

Иногда вам может не потребоваться выделять все дубликаты в таблице, а отображать только последовательные, то есть те, которые расположены рядом друг с другом. 

Для этого выберите область с данными (не включая заголовок) и создайте условное форматирование с одной из следующих формул:

  • Чтобы выделить два идущих друг за другом заказа одного и того же менеджера:

=ИЛИ($G1=$G2;$G2=$G3)

  • Чтобы выделить второй заказ менеджера, если у него 2 заказа идут подряд:
    =$G1=$G2

Здесь мы показали выделение последовательных повторяющихся текстов, но это также будет работать для последовательных повторяющихся чисел и дат.
Если на вашем листе Excel могут быть пустые строки и вы не хотите, чтобы следующие друг за другом пустые ячейки выделялись цветом, внесите следующие улучшения в формулы:

  • при выделении только второго повтора

=И($G2<>""; $G1=$G2)

  • при выделении обоих дублей:

=И($G2<>""; ИЛИ($G1=$G2;$G2=$G3))

Как видите, нет ничего сложного в том, чтобы выделить цветом дубликаты в Excel с помощью условного форматирования. 

Рекомендуем также:

Как посчитать количество повторяющихся значений в Excel? - Зачем считать дубликаты? Мы можем получить ответ на множество интересных вопросов. К примеру, сколько клиентов сделало покупки, сколько менеджеров занималось продажей, сколько раз работали с определённым поставщиком и т.д. Если…
Как убрать повторяющиеся значения в Excel? - В этом руководстве объясняется, как удалять повторяющиеся значения в Excel. Вы изучите несколько различных методов поиска и удаления дубликатов, избавитесь от дублирующих строк, обнаружите точные повторы и частичные совпадения. Хотя…
Как найти повторяющиеся значения в таблице Excel - В этой статье мы рассмотрим разные подходы к одной из самых распространенных и, по моему мнению, важных задач в Excel - как найти в ячейках и в столбцах таблицы повторяющиеся…
Как изменить цвет ячейки в зависимости от значения в Excel? - В этой статье вы найдете 13 примеров как изменить цвет фона ячеек в зависимости от значения в Excel 2016, 2013 и 2010. Кроме того, вы узнаете, как использовать формулы Excel…
Как сделать условное форматирование в Excel? Инструкции с примерами. - В этой статье вы найдете множество быстрых способов как сделать условное форматирование строк, столбцов и отдельных ячеек в MS Excel 2016, 2013 и 2010. Мы рассмотрим, как можно применить различное…