В этом руководстве демонстрируются два простых способа вычисления средневзвешенного значения в Excel - с помощью функции СУММ (SUM) или СУММПРОИЗВ (SUMPRODUCT в английском варианте).

В одной из предыдущих статей мы обсудили три основные функции для вычисления среднего в Excel, которые очень просты и просты в использовании. 

Но что, если некоторые значения более важны, чем другие, и, следовательно, вносят больший вклад в конечное среднее значение?  Например, если вы участвуете в экзаменах и все экзамены имеют одинаковый вес, они одинаково важны, то для вас важно именно среднее значение оценки.

Однако в реальной жизни это не всегда так. Например, если вы изучаете программирование, то насколько важны для вас оценки по истории и физкультуре по сравнению с оценками по профильным дисциплинам?

Некоторые задачи всегда важнее других. Некоторые экзамены важнее других.

В таких ситуациях вам как раз и необходимо рассчитывать средневзвешенное значение.

Хотя Microsoft Excel не предоставляет специальной функции взвешенного среднего, он предоставляет несколько других, которые окажутся полезными в ваших вычислениях, что показано в следующих примерах.

Что такое средневзвешенное значение?

Оно является своего рода средним арифметическим, в котором некоторые элементы набора данных имеют большую значимость, чем другие. Другими словами, каждому исходному показателю присваивается определенный вес.

Оценки учащихся часто рассчитываются с использованием этого подхода, что видно на следующем скриншоте. Обычное среднее значение легко вычисляется с помощью  СРЗНАЧ . Однако мы хотим, чтобы итог учитывал значимость каждого вида занятий, указанного в столбце C.

В математике и статистике вы вычисляете взвешенное среднее значение, умножая каждое число в наборе на его вес, затем складываете произведения и делите итог сложения произведений на сумму всех весомостей.

В этом примере, чтобы посчитать средневзвешенную итоговую оценку, вы умножаете каждый полученный балл на соответствующий процент (преобразованный в десятичную дробь), складываете эти 5 произведений вместе и делите это число на итог сложения пяти весов:

((91 * 0,1) + (85 * 0,05) + (80 * 0,2) + (73 * 0,25) + (68 * 0,4)) / (0,1 + 0,05 + 0,2 + 0,25 + 0,4) = 74,8

Обычная средняя оценка (79,4) и средневзвешенная (74,8) - это разные величины.

Формулы для средневзвешенного значения в Excel

В Microsoft Excel взвешенное среднее рассчитывается с использованием того же подхода, но с гораздо меньшими усилиями, поскольку функции Excel выполнят большую часть работы за вас.

Пример 1. Функция СУММ.

Если у вас есть базовые знания о ней , приведенная ниже формула вряд ли потребует какого-либо объяснения:

=СУММ(B2*C2; B3*C3; B4*C4; B5*C5; B6*C6)/СУММ(C2:C6)

По сути, он выполняет те же вычисления, что и описанные выше, за исключением того, что вы предоставляете ссылки на ячейки вместо чисел.

Посмотрите на рисунок чуть ниже: формула возвращает точно такой же результат, что и вычисления, которые мы делали минуту назад. Обратите внимание на разницу между нормальным средним, возвращаемым при помощи СРЗНАЧ в C8, и средневзвешенным (C9).

Несмотря на то, что формула эта очень проста и понятна, но она не подходит, если вы хотите усреднить большое количество элементов. Ведь придётся перечислять множество аргументов, что довольно утомительно.

В этом случае вам лучше использовать функцию СУММПРОИЗВ (SUMPRODUCT в английской версии). Об этом – ниже.

Пример 2. Функция СУММПРОИЗВ

Она идеально подходит для нашей задачи, так как предназначена для сложения произведений чисел. А это именно то, что нам нужно. 

Таким образом, вместо умножения каждого числа на показатель его значимости по отдельности, вы предоставляете два массива в формуле СУММПРОИЗВ (в этом контексте массив представляет собой непрерывный диапазон ячеек), а затем делите результат на итог сложения весов:

= СУММПРОИЗВ(диапазон_значений ; диапазон_весов ) / СУММ( диапазон_весов )

Предполагая, что величины для усреднения находятся в ячейках B2: B6, а показатели значимости - в ячейках C2: C6, наша формула будет такой:

=СУММПРОИЗВ(B2:B6; C2:C6) / СУММ(C2:C6)

Итак, формула умножает 1- е число в массиве 1 на 1- е  в массиве 2 (в данном примере 91 * 0,1), а затем перемножает 2- е число в массиве 1 на 2- е  в массиве 2 (85 * 0,15). в этом примере) и так далее. Когда все умножения выполнены, Эксель складывает произведения. Затем делим полученное на итог весов.

Чтобы убедиться, что функция СУММПРОИЗВ дает правильный результат, сравните ее с формулой СУММ из предыдущего примера, и вы увидите, что числа идентичны.

В нашем случае сложение весов дает 100%. То есть, это просто процент от итога. В таком случае верный результат может быть получен также следующими способами:

=СУММ(B2*C2; B3*C3; B4*C4; B5*C5; B6*C6)

{=СУММ(B2:B6*C2:C6)}

Это формула массива, не забудьте, что вводить ее нужно при помощи комбинации клавиш CTRL+SHIFT+ENTER.

=СУММПРОИЗВ(B2:B6;C2:C6)

Но при использовании функции СУММ или СУММПРОИЗВ веса совершенно не обязательно должны составлять 100%. Однако, они также не должны быть обязательно выражены в процентах. 

Например, вы можете составить шкалу приоритета / важности и назначить определенное количество баллов для каждого элемента, что и показано на следующем рисунке:

Видите, в этом случае мы обошлись без процентов.

Пример 3. Средневзвешенная цена.

Еще одна достаточно часто встречающаяся проблема – как рассчитать средневзвешенную цену товара. Предположим, мы получили 5 партий товара от различных поставщиков. Мы будем продавать его по одной единой цене. Но чтобы ее определить, нужно знать среднюю цену закупки. В тот здесь нам и пригодится расчет средневзвешенной цены. Взгляните на этот простой пример. Думаю, вам все понятно.

Итак, средневзвешенная цена значительно отличается от обычной средней. На это повлияли 2 больших партии товара по высокой цене. А формулу применяем такую же, как и при расчете любого взвешенного среднего. Перемножаем цену на количество, складываем эти произведения, а затем делим на общее количество товара.

Ну, это все о формуле средневзвешенного значения в Excel. 

Рекомендуем также:

Формула среднего арифметического значения в Excel — функции и примеры - В статье показано, как определить среднее значение в Excel для разных типов данных с помощью формул СРЗНАЧ или СРЗНАЧА. Вы также узнаете, как использовать функции СРЗНАЧЕСЛИ и СРЗНАЧЕСЛИМН для усреднения ячеек,…
Формула суммы в Excel — несколько полезных советов и примеров - Как вычислить сумму в таблице Excel быстро и просто? Попробуйте различные способы: взгляните на сумму выбранных ячеек в строке состояния, используйте автосумму для сложения всех или только нескольких отдельных ячеек,…
7 примеров использования формулы СУММЕСЛИ в Excel с несколькими условиями - В таблицах Excel можно не просто находить сумму чисел, но и делать это в зависимости от заранее определённых критериев отбора. Мы рассмотрим, как правильно применить функцию СУММЕСЛИ (Sumif) в таблицах…
функция сумм 8 простых способов как посчитать в Excel сумму столбца - Как посчитать сумму в Excel быстро и просто? Чаще всего нас интересует итог по столбцу либо строке. Попробуйте различные способы найти сумму по столбцу, используйте функцию СУММ или же преобразуйте…