Как вычислить сумму в таблице Excel быстро и просто? Попробуйте различные способы: взгляните на сумму выбранных ячеек в строке состояния, используйте автосумму для сложения всех или только нескольких отдельных ячеек, примените функцию СУММ или же преобразуйте ваш диапазон в «умную» таблицу для простоты расчетов. Все это мы покажем на примерах.

 Как посчитать сумму одним кликом.

Предположим, имеется таблица, в которой записана выручка по нескольким отделам. Нужно быстро посмотреть общие продажи по одному из них.

Просто нажмите на букву столбца и взгляните на строку состояния Microsoft Excel, чтобы увидеть общее количество выбранных ячеек и сумму их значений.

Будучи очень быстрым, этот метод не позволяет копировать итоговые цифры – можно только посмотреть.

Что такое автосумма в таблице Excel?

Вторым по простоте способом является автосуммирование. Установите курсор в то место, где вы хотите увидеть расчет, а затем используйте кнопку «Автосумма» на вкладке Главная, или комбинацию клавиш  ALT + =.

В активной ячейке появится функция СУММ со ссылками на смежные ячейки. Эксель попытается угадать, что же именно вы хотите сделать. Нажмите ENTER, чтобы закончить ввод формулы.

А если подходящих для расчета чисел рядом не окажется, то просто появится предложение самостоятельно указать область подсчета.

=СУММ()

Этот метод быстрый и позволяет автоматически получать и сохранять результат.

Кроме того, ALT + = можно просто нажать, чтобы быстро поставить формулу в ячейку Excel и не вводить ее руками. Согласитесь, этот небольшой хак в Экселе может сильно ускорить работу.

А если вам нужно быстро сосчитать итоги по вертикали и горизонтали, то здесь также может помочь автосуммирование. Посмотрите это короткое видео, чтобы узнать, как это сделать.

Под видео на всякий случай дано короткое пояснение.

Итак, выберите диапазон ячеек и дополнительно ряд пустых ячеек снизу и справа (то есть, В2:Е14 в приведенном примере).

Нажмите кнопку «Автосумма» на вкладке «Главная» ленты. Формула сложения будет сразу введена.

Ввод функции СУММ вручную.

Самый традиционный способ создать формулу в MS Excel – ввести функцию с клавиатуры. Как обычно, выбираем нужную ячейку и вводим знак =. Затем начинаем набирать СУММ. По первой же букве "С" раскроется список доступных функций, из которых можно сразу выбрать нужную.

ввод функции сумм вручную

Теперь определите диапазон с числами, которые вы хотите сложить, при помощи мыши или же просто введите его с клавиатуры. Если у вас большая область данных для расчетов, то, конечно, руками указать её будет гораздо проще (например, B2:B300). Нажмите Enter.

суммируем столбец вручную

Итак, ваш диапазон просуммирован, в выбранной ячейке вы видите результат. Думаю, вы понимаете, что совершенно то же нужно выполнить, чтобы вычислить его и по строке.

Правила использования формулы суммы в Excel (синтаксис):

СУММ(число1; [число2]; ...)

У нее имеется один обязательный аргумент: число1.

Есть еще и необязательные аргументы (заключенные в квадратные скобки): [число2], ..

Они могут быть числами, ссылками на ячейки, диапазонами, массивами и константами в любой комбинации. Допускается обрабатывать до 255 отдельных аргументов.

К примеру, в выражении =СУММ(D2:D13) только один аргумент - ссылка на ячейки D2:D13.

сумма по строке в Excel

Кстати, в этом случае также имеется возможность воспользоваться автосуммированием.

Накопительное значение, или нарастающий итог.

Задача: По прошествии каждого месяца нужно автоматически определять прибыль, заработанную с начала года. Каждый месяц она будет меняться в зависимости от достигнутого результата.

Посмотрите это небольшое видео, а далее поясним все наши действия.

В ячейке С2 записываем формулу

=СУММ(B$2:B2)

Обратите внимание, что мы использовали в первом адресе абсолютную ссылку на строку 2. То есть, при копировании ячейки с формулой мы всегда будем начинать со 2-й строки.

Устанавливаем курсор в правый нижний угол ячейки и «протаскиваем» до С13. В результате наша формула будет скопирована по всему выделению. И при этом начальный адрес B$2 не изменится. К примеру, в С13 это выглядит так: =СУММ(B$2:B13).

Как видите, нарастающий итог то увеличивается, то уменьшается в зависимости от результата прошедшего месяца.

Использование для проверки введенных значений.

Чтобы разрешить только значения, которые не превышают установленный порог, вы можете использовать проверку данных с пользовательской формулой, основанной на функции СУММ.

Посмотрите это видео, в котором используется инструмент «Проверка данных».

В условии проверки используем формулу

=СУММ(B2:B7)<3500

Правила проверки данных запускаются, как только пользователь добавляет или изменяет значение ячейки.

В этом случае нам нужно условие, которое возвращает ЛОЖЬ до тех пор, пока затраты в смете меньше 3500. Мы используем функцию сложения для обработки фиксированного диапазона, а затем просто сравниваем результат с 3500.

Каждый раз, когда записывается число, запускается проверка. Пока результат остается меньше 3500, проверка успешна. Если какое-то действие приводит к тому, что он превышает 3500, проверка завершается неудачно и выводится сообщение об ошибке.

Подобное же условие допускается использовать и в условном форматировании, когда ячейки с числами могут быть закрашены красным цветом, если их общий итог превысит установленный порог. Более подробно об условном форматировании читайте -

25 способов условного форматирования в Excel

Надеемся, что теперь посчитать сумму области данных или же отдельных ячеек вам будет гораздо проще.

Также рекомендуем:

Функция СЧЁТЕСЛИМН в Excel с несколькими условиями — объясняем на примерах. - В этом руководстве объясняется, как использовать функцию СЧЕТЕСЛИМН с несколькими критериями в Excel на основе логики И и ИЛИ. Вы найдете примеры для разных типов данных - числа, даты, текст,…
СЧЕТЕСЛИ в Excel - примеры функции с одним и несколькими условиями - В этой статье мы сосредоточимся на функции Excel СЧЕТЕСЛИ (COUNTIF в английском варианте), которая предназначена для подсчета ячеек с определённым условием. Сначала мы кратко рассмотрим синтаксис и общее использование, а затем я…
Функция СУММЕСЛИМН - как суммировать ячейки в Excel, когда много условий? - В этом руководстве объясняется различие между функциями СУММЕСЛИ (SUMIF) и СУММЕСЛИМН (SUMIFS) с точки зрения их синтаксиса и использования, а также приводятся примеры формул для суммирования значений с несколькими критериями…
7 примеров использования формулы СУММЕСЛИ в Excel с несколькими условиями - В таблицах Excel можно не просто находить сумму чисел, но и делать это в зависимости от заранее определённых критериев отбора. Мы рассмотрим, как правильно применить функцию СУММЕСЛИ (Sumif) в таблицах…
функция сумм 8 простых способов как посчитать в Excel сумму столбца - Как посчитать сумму в Excel быстро и просто? Чаще всего нас интересует итог по столбцу либо строке. Попробуйте различные способы найти сумму по столбцу, используйте функцию СУММ или же преобразуйте…
проверка правильности ввода Excel при помощи функции ЕСЛИ Как проверить правильность ввода данных в Excel? - Подтверждаем правильность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить…