Как посчитать сумму в Excel быстро и просто? Попробуйте различные способы: взгляните на сумму выбранных ячеек в строке состояния, используйте автосумму для сложения всех или только нескольких отдельных ячеек, посчитайте итог столбца или строки, используйте функцию СУММ или же преобразуйте ваш диапазон в «умную» таблицу для простоты расчетов. Все это мы увидим на примерах.

 Как посчитать сумму одним кликом.

Предположим, имеется таблица, в которой записана выручка по нескольким отделам. Нужно быстро посмотреть общие продажи по одному из них.

Просто нажмите на букву столбца и взгляните на строку состояния Microsoft Excel, чтобы увидеть общее количество выбранных ячеек и сумму их значений.

Будучи очень быстрым, этот метод не позволяет копировать итоговые цифры – можно только посмотреть.

Как посчитать сумму в Excel автосуммированием.

Вторым по простоте способом является автосуммирование. Установите курсор в то место, где вы хотите увидеть расчет, а затем используйте кнопку «Автосумма» на вкладке Главная, или комбинацию клавиш  ALT + =.

В активной ячейке появится функция СУММ со ссылками на смежные ячейки. Эксель попытается угадать, что же именно вы хотите сделать. Нажмите ENTER, чтобы закончить ввод формулы.

А если подходящих для расчета чисел рядом не окажется, то просто возникнет предложение самостоятельно выделить область подсчета.

=СУММ()

Этот метод быстрый и позволяет автоматически получать и сохранять результат.

Кроме того, ALT + = можно просто нажать, чтобы поставить формулу суммы в ячейку Excel и не вводить ее руками. Согласитесь, этот небольшой хак в Экселе может сильно ускорить работу.

А если вам нужно быстро получить итоги по вертикали и горизонтали, то здесь также может помочь автосуммирование. Посмотрите это короткое видео, чтобы узнать, как это сделать.

Под видео на всякий случай дано короткое пояснение.

Итак, выберите диапазон ячеек плюс ряд пустых ячеек снизу и справа (то есть, В2:Е14 в приведенном примере).

Нажмите кнопку «Автосумма» на вкладке «Главная» ленты. Формула сложения будет сразу введена.

Ввод функции вручную.

Самый традиционный способ создать формулу в MS Excel – ввести функцию с клавиатуры. Как обычно, выбираем нужную ячейку и вводим знак =. Затем начинаем набирать СУММ. По первой же букве "С" раскроется список доступных функций, из которых можно сразу выбрать нужную.

ввод функции сумм вручную

Теперь определите диапазон с числами, которые вы хотите сложить, при помощи мыши или же просто введите его с клавиатуры. Если у вас большая область данных для расчетов, то, конечно, руками указать её будет гораздо проще (например, B2:B300). Нажмите Enter.

суммируем столбец вручную

Итак, ваш диапазон просуммирован, в выбранной ячейке вы видите результат. Думаю, вы понимаете, что совершенно то же нужно выполнить, чтобы вычислить его и по строке.

Правила использования формулы суммы в Excel (синтаксис):

СУММ(число1; [число2]; ...)

У нее имеется один обязательный аргумент: число1.

Есть еще и необязательные аргументы (заключенные в квадратные скобки): [число2], ..

Они могут быть числами, ссылками на ячейки, диапазонами, массивами и константами в любой комбинации. Допускается обрабатывать до 255 отдельных аргументов.

К примеру, в выражении =СУММ(D2:D13) только один аргумент - ссылка на ячейки D2:D13.

сумма по строке в Excel

Кстати, в этом случае также имеется возможность воспользоваться автосуммированием.

Как суммировать весь столбец либо строку.

Если мы вводим функцию вручную, то в вашей таблице Excel появляются различные возможности расчетов.

Если ввести

=СУММ(B:B)

то получим общую выручку по первому отделу.

сумма по всему столбцу целиком

Обратите внимание, что наличие текста, а не числа, в ячейке B1 никак не сказалось на вычислениях. Суммируются только числовые значения, а символьные – игнорируются.

Важное замечание! Если среди чисел случайно окажется дата, то это окажет серьезное влияние на правильность расчетов. Дело в том, что даты хранятся в Excel в виде чисел, и отсчет начинается с 1900 года ежедневно. Поэтому будьте внимательны, рассчитывая сумму столбца в Excel и используя его в формуле целиком.

Все сказанное выше целиком и полностью относится к работе со строками.

сумма по строке

Но суммирование столбца целиком встречается достаточно редко. Гораздо чаще область, с которой мы будем работать, нужно указывать более тонко и точно.

Суммируем диапазон ячеек.

Важно научиться правильно указать диапазон данных. Вот как это сделать, если суммировать продажи за 1-й квартал:

сумма диапазона

Формула расчета выглядит так:

=СУММ(B2:D4)

Вы также можете применить ее и для нескольких областей, которые не пересекаются между собой и находятся в разных местах вашей электронной таблицы.

В формуле последовательно перечисляем несколько диапазонов:

=СУММ(B2:D4;B8:D10)

Естественно, их может быть не два, а гораздо больше: до 255 штук.

Накопительная сумма, или нарастающий итог.

Задача: По прошествии каждого месяца нужно автоматически определять прибыль, заработанную с начала года. Каждый месяц она будет меняться в зависимости от достигнутого результата.

Посмотрите это небольшое видео, а далее поясним все наши действия.

В ячейке С2 записываем формулу суммы

=СУММ(B$2:B2)

Обратите внимание, что мы использовали в первом адресе абсолютную ссылку на строку 2. То есть, при копировании ячейки с формулой мы всегда будем начинать со 2-й строки.

Устанавливаем курсор в правый нижний угол ячейки и «протаскиваем» до С13. В результате наша формула будет скопирована по всему выделению. И при этом начальный адрес B$2 не изменится. К примеру, в С13 это выглядит так: =СУММ(B$2:B13).

Как видите, нарастающий итог то увеличивается, то уменьшается в зависимости от результата прошедшего месяца.

Как вычислить сумму каждой N-ой строки.

В таблице расположены повторяющиеся с определенной периодичностью показатели - продажи по отделам. Необходимо рассчитать общую выручку по каждому из них. Сложность в том, что интересующие нас показатели находятся не рядом, а чередуются. Предположим, мы анализируем сведения о продажах трех отделов помесячно. Необходимо определить продажи по каждому отделу.

Иначе говоря, нужно, двигаясь вниз, взять каждую третью строку.

сумма каждой третьей строки

Это можно сделать двумя способами.

Первый – самый простой, «в лоб». Складываем все цифры нужного отдела обычной математической операцией сложения. Выглядит просто, но представьте, если у вас статистика, предположим, за 3 года? Придется обработать 36 чисел…

Второй способ – для более «продвинутых», но зато универсальный.

Записываем

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)+1;3)=0;C2:C16))

И затем нажимаем комбинацию клавиш CTRL+SHIFT+ENTER, поскольку используется формула массива. Excel сам добавит к фигурные скобки слева и справа.

Как это работает? При помощи функции СТРОКА мы вычисляем номер текущей строки. И если остаток от деления на 3 будет равен нулю, то значение из этой позиции будет учтено в расчете. В противном случае – нет. Но наше первое число находится во второй строке таблицы. Поскольку надо начинать с первой позиции и потом брать каждую третью, а начинается диапазон со 2-й строки, то к порядковому номеру её добавляем 1. Для этого и служит выражение СТРОКА(C2:C16)+1. Получим 2+1=3, остаток от деления на 3 равен нулю. Так мы возьмем 1-ю, 3-ю, 6-ю и т.д. позиции.

Формула массива означает, что Excel должен последовательно перебрать все ячейки диапазона – начиная с C2 до C16, и с каждой из них произвести описанные выше операции.

Когда будем находить продажи по Отделу 2, то изменим выражение:

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16);3)=0;C2:C16))

Ничего не добавляем, поскольку первое подходящее значение как раз и находится в 3-й строке.

Аналогично для Отдела 3

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)-1;3)=0;C2:C16))

Вместо добавления 1 теперь вычитаем 1, чтобы отсчет вновь начался с 3. Теперь брать будем каждую третью строку, начиная с 4-й.

Ну и, конечно, не забываем нажимать CTRL+SHIFT+ENTER.

Сумма каждых N строк.

В таблице Excel записана ежедневная выручка магазина. Необходимо рассчитать еженедельную выручку за каждую неделю.

находим сумму групп строк

Используем то, что СУММ может складывать значения не только в диапазоне данных, но и в массиве. Такой массив значений ей может предоставить функция СМЕЩ.

Напомним, что здесь нужно указать несколько аргументов:

1.       Начальную точку. Обратите внимание, что С2 мы ввели как абсолютную ссылку.

2.       Сколько шагов вниз сделать

3.       Сколько шагов вправо сделать. После этого попадаем в начальную (левую верхнюю) точку массива.

4.       Сколько значений взять, вновь двигаясь вниз.

5. Сколько колонок будет в массиве. Попадаем в конечную (правую нижнюю) точку массива значений.

Итак, формула для 1-й недели:

=СУММ(СМЕЩ($C$2;(СТРОКА()-2)*5;0;5;1))

В данном случае СТРОКА() – это как бы наш счетчик недель. Отсчет нужно начинать с 0, чтобы действия начать прямо с ячейки C2, никуда вниз не перемещаясь. Для этого используем СТРОКА()-2. Поскольку сама формула находится в ячейке F2, получаем в результате 0. Началом отсчета будет С2, а конец его – на 5 значений ниже в той же колонке.

СУММ просто сложит предложенные ей пять значений.

Для 2-й недели в F3 формулу просто копируем. СТРОКА()-2 даст здесь результат 1, поэтому начало массива будет 1*5=5, то есть на 5 значений вниз в ячейке C7 и до С11. И так далее.

Как найти сумму наибольших (наименьших) значений. 

Задача: Суммировать 3 максимальных или 3 минимальных значения.

сумма наибольших или наименьших чисел

Функция НАИБОЛЬШИЙ возвращает самое большое значение из перечня данных. Хитрость в том, что второй ее аргумент показывает, какое именно значение нужно вернуть: 1- самое большое, 2 – второе по величине и т.д. А если указать {1;2;3} – значит, нужны три самых больших. Но при этом не забывайте применять формулу массива и завершать комбинацией клавиш CTRL+SHIFT+ENTER.

=СУММ(НАИБОЛЬШИЙ(B2:D13;{1;2;3}))

Аналогично обстоит дело и с самыми маленькими значениями:

=СУММ(НАИМЕНЬШИЙ(B2:D13;{1;2;3}))

3-D сумма, или работаем с несколькими листами рабочей книги Excel.

Чтобы подсчитать цифры из одинаковой формы диапазона на нескольких листах, вы можете записывать координаты данных специальным синтаксисом, называемым «3d-ссылка».

Предположим, на каждом отдельном листе вашей рабочей книги имеется таблица с данными за неделю. Вам нужно свести все это в единое целое и получить свод за месяц. Для этого будем ссылаться на четыре листа.

Посмотрите на этом небольшом видео, как применяются 3-D формулы.

Как видите, у нас имеется 4 одинаковых таблицы. Стандартный метод нахождения выручки за месяц –

=СУММ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

В качестве аргументов перечисляем диапазоны данных.

А вот 3D-метод:

=СУММ(неделя1:неделя4!B2:B8)

Мы указываем программе, что нужно произвести вычисления с ячейками B2:B8, находящимися на листах неделя1, неделя2, неделя3, неделя4. Здесь номер листа последовательно увеличивается на 1.

Важное замечание. Вы можете пользоваться 3D-ссылками и в других случаях. К примеру, выражение

=СРЗНАЧ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

найдет среднее значение однодневной выручки за месяц.

Поиск и расчет суммы.

Имеются сведения о продаже товаров, для каждого из них выделен отдельная колонка. Необходимо рассчитать продажи по выбранному товару.

Для поиска и выбора нужного товара используем весьма популярную комбинацию функций ИНДЕКС+ПОИСКПОЗ.

сумма столбца

Расчет суммы в G3 выполним так:

=СУММ(ИНДЕКС(B2:D21;0;ПОИСКПОЗ(F3;B1:D1;0)))

Итак, комбинация ИНДЕКС+ПОИСКПОЗ должны возвратить для дальнейших расчетов набор чисел в виде вертикального массива, который и будет потом просуммирован.

ПОИСКПОЗ находит в B1:D1 нужный продукт (бананы) и возвращает его порядковый номер (иначе говоря, 2).

ИНДЕКС выбирает из массива значений B2:D21 соответствующий номер столбца (второй). Будет возвращен весь столбик данных с соответствующим номером, поскольку номер строки (первый параметр функции) указан равным 0. Остается только подсчитать все значения в этой колонке.

В данном случае, чтобы избежать ошибок при записи названия товара, мы рекомендовали бы использовать выпадающий список в F3.

5 способов создать выпадающий список в Excel - рекомендуем ознакомиться.

Сумма из нескольких таблиц.

Для получения итогов сразу по нескольким таблицам также используем функцию СУММ и структурированные ссылки. Такие ссылки появляются при создании в Excel «умной» таблицы.

При создании её Excel назначает имя самой таблице и каждому заголовку колонки в ней. Эти имена затем можно использовать в выражениях: они могут отображаться в виде подсказок в строке ввода.

использование именованных диапазонов

В нашем случае это выглядит так:

Прямая ссылкаСтруктурированная ссылка (Имя таблицы и столбца)
B2:B21Таблица2[Сумма]

Для создания «умной» таблицы выделим диапазон A1:B21 и на ленте «Главная» выбираем «Форматировать как таблицу».

Приятным бонусом здесь является то, что «умная» таблица сама изменяет свои размеры при добавлении в нее данных (или же их удалении), ссылки на нее корректировать не нужно.

Также в нашем случае не принципиально, где именно располагаются в вашем файле Excel эти данные. Даже не важно, что они находятся на разных листах – программа все равно найдет их по имени.

Помимо этого, если используемые вами таблицы содержат строку итогов, то нашу формулу перепишем так:

=СУММ(Таблица2[#Итоги];Таблица3[#Итоги])

И если будут внесены какие-то изменения или добавлены цифры, то всепересчитается автоматически.

Примечание: итоговая строка в таблице должна быть включена. Если вы отключите её, то выражение вернет ошибку #ССЫЛКА.

Еще одно важное замечание. Чуть выше мы с вами говорили, что функция СУММ подсчитывает все значения в строке или столбце – даже если они скрыты или же установленный фильтр не позволяет их увидеть.

В нашем случае, если включена строка итогов, вы с ее помощью получите сумму только видимых ячеек.

сумма видимых ячеек

Как вы видите на этом рисунке, если отфильтровать часть значений, то общие продажи, рассчитанные вторым способом, изменятся. В то время как если просто складывать ячейки и не использовать итоговую строку, то фильтр не меняет результат вычислений.

Использование для проверки введенных значений.

Чтобы разрешить только значения, которые не превышают установленный порог, вы можете использовать проверку данных с пользовательской формулой, основанной на функции СУММ.

Посмотрите это видео, в котором используется инструмент «Проверка данных».

В условии проверки используем формулу

=СУММ(B2:B7)<3500

Правила проверки данных запускаются, как только пользователь добавляет или изменяет значение ячейки.

В этом случае нам нужно условие, которое возвращает ЛОЖЬ до тех пор, пока затраты в смете меньше 3500. Мы используем функцию сложения для обработки фиксированного диапазона, а затем просто сравниваем результат с 3500.

Каждый раз, когда записывается число, запускается проверка. Пока результат остается меньше 3500, проверка успешна. Если какое-то действие приводит к тому, что он превышает 3500, проверка завершается неудачно и выводится сообщение об ошибке.

Подобное же условие допускается использовать и в условном форматировании, когда ячейки с числами могут быть закрашены красным цветом, если их сумма превысит установленное значение. Более подробно об условном форматировании читайте -

25 способов условного форматирования в Excel

Надеемся, что теперь суммировать области данных или же отдельные ячейки вам будет гораздо проще.

Также рекомендуем:

Функция СЧЁТЕСЛИМН в Excel с несколькими условиями — объясняем на примерах. - В этом руководстве объясняется, как использовать функцию СЧЕТЕСЛИМН с несколькими критериями в Excel на основе логики И и ИЛИ. Вы найдете примеры для разных типов данных - числа, даты, текст,…
СЧЕТЕСЛИ в Excel - примеры функции с одним и несколькими условиями - В этой статье мы сосредоточимся на функции Excel СЧЕТЕСЛИ (COUNTIF в английском варианте), которая предназначена для подсчета ячеек с определённым условием. Сначала мы кратко рассмотрим синтаксис и общее использование, а затем я…
Функция СУММЕСЛИМН - как суммировать ячейки в Excel, когда много условий? - В этом руководстве объясняется различие между функциями СУММЕСЛИ (SUMIF) и СУММЕСЛИМН (SUMIFS) с точки зрения их синтаксиса и использования, а также приводятся примеры формул для суммирования значений с несколькими критериями…
7 примеров использования формулы СУММЕСЛИ в Excel с несколькими условиями - В таблицах Excel можно не просто находить сумму чисел, но и делать это в зависимости от заранее определённых критериев отбора. Мы рассмотрим, как правильно применить функцию СУММЕСЛИ (Sumif) в таблицах…
проверка правильности ввода Excel при помощи функции ЕСЛИ Как проверить правильность ввода данных в Excel? - Подтверждаем правильность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить…